Problem?

klv30907

New member
I’ve had my JL for 17 days and everything has been wonderful. This morning I get in, and the backup camera wasn’t working. I tried turning on the radio—nothing. I shut it down and cranked it back up and the radio came on but wouldn’t turn back off. I drove to work and shut it down again. When I restarted it, the issue remained the same, no backup camera and the radio wouldn’t shut off plus the air conditioner kicked on all by itself. I suppose I should take it in but I’m wondering if it could just be a glitch that will work itself out?


Sent from my iPhone using JL Wrangler Jeep Forum mobile app
 

wayoflife

Administrator
Staff member
JeepFan here on the forum had a similar problem but not the same. He ultimately had to take his JL into the dealership to have it and other problems with his headunit fixed.
 

JeepCares

New member
I’ve had my JL for 17 days and everything has been wonderful. This morning I get in, and the backup camera wasn’t working. I tried turning on the radio—nothing. I shut it down and cranked it back up and the radio came on but wouldn’t turn back off. I drove to work and shut it down again. When I restarted it, the issue remained the same, no backup camera and the radio wouldn’t shut off plus the air conditioner kicked on all by itself. I suppose I should take it in but I’m wondering if it could just be a glitch that will work itself out?


Sent from my iPhone using JL Wrangler Jeep Forum mobile app

Hi klv30907,
We understand how this could be frustrating, but recognize that you are just reaching out to other forum members at this time. If you do wish to visit a dealer to have this looked into further, let us know! Just send us a private message with additional details. We would be more than happy to assist.
Julie
Jeep Social Care Specialist
 

klv30907

New member
Hi klv30907,
We understand how this could be frustrating, but recognize that you are just reaching out to other forum members at this time. If you do wish to visit a dealer to have this looked into further, let us know! Just send us a private message with additional details. We would be more than happy to assist.
Julie
Jeep Social Care Specialist

I do recognize I’m just reaching out to forum members. I wanted to know if it was common. Right now it’s working fine. I will wait to see if it reoccurring before heading to a dealer. Thanks


Sent from my iPhone using JL Wrangler Jeep Forum mobile app
 

JSTucson

New member
I’ve had my JL for 17 days and everything has been wonderful. This morning I get in, and the backup camera wasn’t working. I tried turning on the radio—nothing. I shut it down and cranked it back up and the radio came on but wouldn’t turn back off. I drove to work and shut it down again. When I restarted it, the issue remained the same, no backup camera and the radio wouldn’t shut off plus the air conditioner kicked on all by itself. I suppose I should take it in but I’m wondering if it could just be a glitch that will work itself out?


Sent from my iPhone using JL Wrangler Jeep Forum mobile app
I had same backup camera issue this morning on new (200 miles) JL. The camera worked fine when I backed out of my garage, but after being parked for an hour I got back in and no camera, no camera ..... Drove home, tried again, still no camera. Saw lots of others have same issue so I waited couple hours and now the camera is back working as it should.
 

Top