Results 1 to 6 of 6

Thread: 18 JLUR sway bar disconnect malfunction

  1. #1

    18 JLUR sway bar disconnect malfunction

    While off roading and doing some serious rock garden crawling, I was getting Shifter error's and Sway bar disconnect errors. This has not happened before. Shutting off vehicle corrected each time this happened, which was more than once.
    I just pressure washed the mud and rocks off, vacuumed inside then drove out to fill tank for the week. I remembered the events of the weekend and when I got back into driveway, put into 4L and attempted to disconnect sway bar. I can hear the subtle 'kink' which is sound it normally makes...but it says Connected. Tried this four or five times and each time the same. It is not Dis-connecting.
    I have no error message. Has this occurred to anyone here?

  2. #2
    Fresh Catch asmith1923's Avatar
    Join Date
    Sep 2019
    Location
    Aldie
    Posts
    42
    Quote Originally Posted by BlueRubicon View Post
    While off roading and doing some serious rock garden crawling, I was getting Shifter error's and Sway bar disconnect errors. This has not happened before. Shutting off vehicle corrected each time this happened, which was more than once.
    I just pressure washed the mud and rocks off, vacuumed inside then drove out to fill tank for the week. I remembered the events of the weekend and when I got back into driveway, put into 4L and attempted to disconnect sway bar. I can hear the subtle 'kink' which is sound it normally makes...but it says Connected. Tried this four or five times and each time the same. It is not Dis-connecting.
    I have no error message. Has this occurred to anyone here?
    No, but I did Eddies mod of disconnecting the hanger and rotating the module back 90 deg to give me more ground clearance. Once you take the muffler hanger off it freely spins. Maybe try disconnecting that and rotating it by hand a couple times then reconnecting it. It may just be stuck. A lot quicker than taking it to the stealership.


    Tony
    19 JLUR Mojito!

  3. #3
    Been Around the Block JeepJL's Avatar
    Join Date
    Nov 2018
    Location
    Oregon
    Posts
    267
    So after a week on the JL Experience I was having all kinds of swaybar, service 4wd, abs issues, and radio reboots. They would happen at different times. On day 5 I was getting frustrated and decided to unplug my tazer from the OBD port and after that I had zero issues. It was an instant fix. If you have a tazer plugged in Id try to remove it and see what that does for you. I always wondered if that was my issue.


    Sent from my iPhone using JL Wrangler Jeep Forum mobile app

  4. #4
    Hooked StormBreakerTheJL's Avatar
    Join Date
    Jul 2019
    Location
    Colorado Springs
    Posts
    186
    Quote Originally Posted by JeepJL View Post
    So after a week on the JL Experience I was having all kinds of swaybar, service 4wd, abs issues, and radio reboots. They would happen at different times. On day 5 I was getting frustrated and decided to unplug my tazer from the OBD port and after that I had zero issues. It was an instant fix. If you have a tazer plugged in Id try to remove it and see what that does for you. I always wondered if that was my issue.


    Sent from my iPhone using JL Wrangler Jeep Forum mobile app
    Faulty Tazer? Or what do you think the issue was?

  5. #5
    Been Around the Block JeepJL's Avatar
    Join Date
    Nov 2018
    Location
    Oregon
    Posts
    267
    Quote Originally Posted by StormBreakerTheJL View Post
    Faulty Tazer? Or what do you think the issue was?
    You know, Im not gonna say that but ever since I plugged it in odd bugs pop up. I think its just the nature of the beast. The JL is an electrical nightmare compared to the JK. The amount of BCMs compared to the JK is insane. For some reason my right rear brake kept locking up and I could feel the abs module applying the pressure in 4wd with the tazer plugged in. Im on the current software on both the JL and Tazer.


    Sent from my iPhone using JL Wrangler Jeep Forum mobile app

  6. #6
    Knows a Thing or Two ddays v2's Avatar
    Join Date
    Aug 2017
    Location
    Darlington, Pa
    Posts
    503
    In a similar vein, anyone ever figure out the "cut the purple wire" trick that kills the JK ESC & ABS for the JL's?
    2014 JKU Money Pit on 37's
    2019 JLUR on 35's (so far)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •