Page 3 of 3 FirstFirst 123
Results 21 to 22 of 22

Thread: New Owners....CHECK YOUR FUSES.

  1. #21
    Fresh Catch
    Join Date
    Jul 2019
    Location
    Nevada
    Posts
    14
    I started to get a regular Start/Stop warning light after a few thousand miles. It usually happened first start of the day. I finally checked the fuses and relays in the TIPM and found about half the fuses and all the relays could be seated further (click!).

    That was a couple of weeks ago. No warning light since.

  2. #22
    Caught the Bug Shadow's_Jepp's Avatar
    Join Date
    Jan 2018
    Location
    Keizer, Oregon
    Posts
    71
    Quote Originally Posted by NFRs2000NYC View Post
    So it seems that MANY electrical problems with the JL that people have been experiencing are actually due to poorly seated factory fuses. Seems like they are not getting installed properly at the factory, and are vibrating loose, so, when you bring home your shiny new Jeep, pop the hood, pop the fuse cover near the battery, and push down on all the fuses and relays. Most report having at least a few fuses click in. Takes a few minutes, and can save you a lot of head scratching, getting stranded, dealer visits, etc. Happy motoring!
    When the ESS started acting up on our 19 JL After three trips to the dealer, they found that the F10 fuse was not only loose but had cracked in two. They replaced it no more problems.

    His - 09 JKU Wrangler X 3.8 6spd.
    Her's 19 JL Wrangler Sport 3.6 8 speed
    Last edited by Shadow's_Jepp; 11-05-2019 at 07:49 AM.
    Shadow's_Jeep

Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •