Page 3 of 3 FirstFirst 123
Results 21 to 27 of 27

Thread: Paint issue?

  1. #21
    Fresh Catch jrzJL's Avatar
    Join Date
    Apr 2018
    Location
    New Jersey
    Posts
    33
    I have a white JLUR. And my grill is yellowing also


    Sent from my iPhone using JL Wrangler Jeep Forum mobile app

  2. #22
    Been Around the Block scoobycarolanNC's Avatar
    Join Date
    Mar 2018
    Location
    Raleigh, NC
    Posts
    275
    Any updates from the people seeing this?

  3. #23

  4. #24
    Caught the Bug JLJourney18's Avatar
    Join Date
    May 2018
    Location
    Louisiana
    Posts
    61
    Ours appears to be starting to yellow also after 4K miles and three months. I'm curious to hear what comes out of this


    Sent from my iPhone using JL Wrangler Jeep Forum mobile app

  5. #25
    Fresh Catch CalsJLUR's Avatar
    Join Date
    May 2018
    Location
    Lenexa, KS
    Posts
    38
    Sorry for the delay, not enough to time in the day!

    Contacted my Dealer about a couple of issues, one was the yellowing of the grill (especially around the edges) and was told to bring it in so they could look at it. Dropped it off and a week later it was fixed. Grill was repainted and they did an excellent job, extremely happy with it!

    Cause is still a unknown, although the body shop said it looked like some chemical was applied to the base coat. Not sure if this helps or not.


    Sent from my iPhone using JL Wrangler Jeep Forum mobile app
    Attached Images Attached Images

  6. #26
    Caught the Bug Napalm's Avatar
    Join Date
    May 2019
    Location
    Tyler, TX
    Posts
    54
    Bumping this thread... 2019 JLUR in bright white, less than 1100 miles.
    C748934A-F66C-4999-886B-14B943E5FFA1.jpg

    Dealer snapped some pictures.. and sent it off to Jeep to see if they will fix it under warranty. Any of you guys on here that have had this issue... have you had any problems with the dealer or Jeep wanting to warranty it? If so.. what always your next step after the dealer told you no?

  7. #27
    Caught the Bug
    Join Date
    Nov 2018
    Location
    NJ
    Posts
    57
    This happened to me and my dealer painted. Its fine now.

Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •